FAQ

Ti serve aiuto, guarda qui.

Please select your question category

ITA LANGUAGE: Un software gestionale che ti aiuta ad organizzare le attività commerciali della tua azienda. FabariaGest permette di gestire in modo semplice e intuitivo fatture, prezzi, schede prodotto, clienti e molto altro. Dopo una semplice installazione, il programma è già pronto per l'utilizzo e non ha bisogno altre operazioni. Grazie alla struttura del database, la ricerca degli elementi negli archivi è facile ed estremamente veloce. Puoi esportare tutti i documenti (clienti, fornitori, articoli, preventivi, ordini, inventari, elenchi vari..) nei principali formati d'uso (.csv, .xls, .pdf).

ENG LANGUAGE: A management software that helps you to organize business activities of your company. FabariaGest allows to manage in a simple and intuitive invoices, prices, products, customers, and more. After a simple installation, the program is already ready to use and does not need other operations. Thanks to the structure of the database, searching for items in the archives is easy and extremely fast. You can export all the documents (customers, suppliers, articles, quotes, orders, inventories, lists various ..) in the main formats in use (.csv, .xls, .pdf).

Requires: qt5-qtbase
Requires: qt5-plugin-mysql
Requires: mariadb
Requires: mariadb-libs
Requires: mariadb-server
Requires: python-dropbox
Requires: PyQt4
Requires: python ( 2.7 )
Requires: python-sip ( 2.7 and 3 )

BuildRequires: PyQt4-devel
BuildRequires: qt5-devel ( all )

Installazione FabariaGest
tar -xvzf fabaria_gest_1.0.tar.gz

cd fabaria_gest_1.0
Se si compila con le Qt versione 4
allora eseguire il seguente comando

cmake -DMAKE_INSTALL_PREFIX=directory -DWANT_QT4=ON -DWANT_QWT=ON

altrimenti per compilare con le Qt in versione 5
eseguire il seguente comando

cmake -DMAKE_INSTALL_PREFIX=directory -DWANT_QT5=ON -DWANT_QWTQT5=ON

make-j5
sudo make install

Ecco le patch da copiare nella cartella fabariagest-1.0

esistenza_all-ui.patch

--- fabaria/ui/esistenza_all.ui 2015-05-17 20:04:41.000000000 +0200
+++ fabaria/ui/esistenza_all_new.ui 2015-06-12 08:56:18.832424110 +0200
@@ -228,7 +228,7 @@
<customwidget>
<class>QwtPlot</class>
<extends>QFrame</extends>
- <header>qwt/qwt_plot.h</header>
+ <header>qwt_plot.h</header>
</customwidget>
</customwidgets>
<resources>

esistenza_all.patch

--- fabaria/esistenza_all.h 2015-06-11 14:28:05.000000000 +0200
+++ fabaria/esistenza_all_new.h 2015-06-12 08:53:02.887305700 +0200
@@ -5,15 +5,15 @@
#include <QtSql>
#include <QFileDialog>
#include <QCompleter>
-#include <qwt/qwt_plot.h>
-#include <qwt/qwt_plot_curve.h>
-#include <qwt/qwt_plot_grid.h>
-#include <qwt/qwt_symbol.h>
-#include <qwt/qwt_legend.h>
-#include <qwt/qwt_plot_canvas.h>
-#include <qwt/qwt_plot_panner.h>
-#include <qwt/qwt_plot_zoomer.h>
-#include <qwt/qwt_plot_renderer.h>
+#include <qwt_plot.h>
+#include <qwt_plot_curve.h>
+#include <qwt_plot_grid.h>
+#include <qwt_symbol.h>
+#include <qwt_legend.h>
+#include <qwt_plot_canvas.h>
+#include <qwt_plot_panner.h>
+#include <qwt_plot_zoomer.h>
+#include <qwt_plot_renderer.h>
//#include <qwt/qwt_global.h>

namespace Ui {

esistenza_articoli-ui.patch

--- fabaria/ui/esistenza_articoli.ui 2015-05-17 21:56:50.000000000 +0200
+++ fabaria/ui/esistenza_articoli_new.ui 2015-06-12 08:56:38.542140136 +0200
@@ -86,7 +86,7 @@
<customwidget>
<class>QwtPlot</class>
<extends>QFrame</extends>
- <header>qwt/qwt_plot.h</header>
+ <header>qwt_plot.h</header>
</customwidget>
</customwidgets>
<tabstops>

esistenza_articoli.patch

--- fabaria/esistenza_articoli.h 2015-05-24 16:45:10.000000000 +0200
+++ fabaria/esistenza_articoli_new.h 2015-06-12 08:53:44.670823637 +0200
@@ -6,17 +6,17 @@
#include <QtSql>
#include <QFileDialog>
#include <QCompleter>
-#include <qwt/qwt_plot.h>
-#include <qwt/qwt_plot_curve.h>
-#include <qwt/qwt_plot_grid.h>
-#include <qwt/qwt_symbol.h>
-#include <qwt/qwt_legend.h>
-#include <qwt/qwt_plot_canvas.h>
-#include <qwt/qwt_plot_panner.h>
-#include <qwt/qwt_scale_draw.h>
-#include <qwt/qwt_plot_zoomer.h>
-#include <qwt/qwt_plot_renderer.h>
-#include <qwt/qwt_plot_intervalcurve.h>
+#include <qwt_plot.h>
+#include <qwt_plot_curve.h>
+#include <qwt_plot_grid.h>
+#include <qwt_symbol.h>
+#include <qwt_legend.h>
+#include <qwt_plot_canvas.h>
+#include <qwt_plot_panner.h>
+#include <qwt_scale_draw.h>
+#include <qwt_plot_zoomer.h>
+#include <qwt_plot_renderer.h>
+#include <qwt_plot_intervalcurve.h>

namespace Ui {
class esistenza_articoli;

Ecco le patch da copiare nella cartella fabariagest-1.0

esistenza_all-ui.patch

--- fabaria/ui/esistenza_all.ui 2015-05-17 20:04:41.000000000 +0200
+++ fabaria/ui/esistenza_all_new.ui 2015-06-12 09:47:47.569883097 +0200
@@ -228,7 +228,7 @@
<customwidget>
<class>QwtPlot</class>
<extends>QFrame</extends>
- <header>qwt/qwt_plot.h</header>
+ <header>qwt6/qwt_plot.h</header>
</customwidget>
</customwidgets>
<resources>

esistenza_all.patch

--- fabaria/esistenza_all.h 2015-06-11 14:28:05.000000000 +0200
+++ fabaria/esistenza_all_new.h 2015-06-12 09:47:02.882249023 +0200
@@ -5,15 +5,15 @@
#include <QtSql>
#include <QFileDialog>
#include <QCompleter>
-#include <qwt/qwt_plot.h>
-#include <qwt/qwt_plot_curve.h>
-#include <qwt/qwt_plot_grid.h>
-#include <qwt/qwt_symbol.h>
-#include <qwt/qwt_legend.h>
-#include <qwt/qwt_plot_canvas.h>
-#include <qwt/qwt_plot_panner.h>
-#include <qwt/qwt_plot_zoomer.h>
-#include <qwt/qwt_plot_renderer.h>
+#include <qwt6/qwt_plot.h>
+#include <qwt6/qwt_plot_curve.h>
+#include <qwt6/qwt_plot_grid.h>
+#include <qwt6/qwt_symbol.h>
+#include <qwt6/qwt_legend.h>
+#include <qwt6/qwt_plot_canvas.h>
+#include <qwt6/qwt_plot_panner.h>
+#include <qwt6/qwt_plot_zoomer.h>
+#include <qwt6/qwt_plot_renderer.h>
//#include <qwt/qwt_global.h>

namespace Ui {

esistenza_articoli-ui.patch

--- fabaria/ui/esistenza_articoli.ui 2015-05-17 21:56:50.000000000 +0200
+++ fabaria/ui/esistenza_articoli_new.ui 2015-06-12 09:48:06.512575766 +0200
@@ -86,7 +86,7 @@
<customwidget>
<class>QwtPlot</class>
<extends>QFrame</extends>
- <header>qwt/qwt_plot.h</header>
+ <header>qwt6/qwt_plot.h</header>
</customwidget>
</customwidgets>
<tabstops>

esistenza_articoli.patch

--- fabaria/esistenza_articoli.h 2015-05-24 16:45:10.000000000 +0200
+++ fabaria/esistenza_articoli_new.h 2015-06-12 09:47:34.020387638 +0200
@@ -6,17 +6,17 @@
#include <QtSql>
#include <QFileDialog>
#include <QCompleter>
-#include <qwt/qwt_plot.h>
-#include <qwt/qwt_plot_curve.h>
-#include <qwt/qwt_plot_grid.h>
-#include <qwt/qwt_symbol.h>
-#include <qwt/qwt_legend.h>
-#include <qwt/qwt_plot_canvas.h>
-#include <qwt/qwt_plot_panner.h>
-#include <qwt/qwt_scale_draw.h>
-#include <qwt/qwt_plot_zoomer.h>
-#include <qwt/qwt_plot_renderer.h>
-#include <qwt/qwt_plot_intervalcurve.h>
+#include <qwt6/qwt_plot.h>
+#include <qwt6/qwt_plot_curve.h>
+#include <qwt6/qwt_plot_grid.h>
+#include <qwt6/qwt_symbol.h>
+#include <qwt6/qwt_legend.h>
+#include <qwt6/qwt_plot_canvas.h>
+#include <qwt6/qwt_plot_panner.h>
+#include <qwt6/qwt_scale_draw.h>
+#include <qwt6/qwt_plot_zoomer.h>
+#include <qwt6/qwt_plot_renderer.h>
+#include <qwt6/qwt_plot_intervalcurve.h>

namespace Ui {
class esistenza_articoli;

Ecco le patch da copiare nella cartella fabariagest-1.0

esistenza_all-ui.patch

--- fabariagest-1.0/fabaria/ui/esistenza_all.ui 2015-05-17 20:04:41.000000000 +0200
+++ fabariagest-1.0/fabaria/ui/esistenza_all_new.ui 2015-06-12 09:47:47.569883097 +0200
@@ -228,7 +228,7 @@
<customwidget>
<class>QwtPlot</class>
<extends>QFrame</extends>
- <header>qwt/qwt_plot.h</header>
+ <header>qwt6/qwt_plot.h</header>
</customwidget>
</customwidgets>
<resources>

esistenza_all.patch

--- fabariagest-1.0/fabaria/esistenza_all.h 2015-06-11 14:28:05.000000000 +0200
+++ fabariagest-1.0/fabaria/esistenza_all_new.h 2015-06-12 09:47:02.882249023 +0200
@@ -5,15 +5,15 @@
#include <QtSql>
#include <QFileDialog>
#include <QCompleter>
-#include <qwt/qwt_plot.h>
-#include <qwt/qwt_plot_curve.h>
-#include <qwt/qwt_plot_grid.h>
-#include <qwt/qwt_symbol.h>
-#include <qwt/qwt_legend.h>
-#include <qwt/qwt_plot_canvas.h>
-#include <qwt/qwt_plot_panner.h>
-#include <qwt/qwt_plot_zoomer.h>
-#include <qwt/qwt_plot_renderer.h>
+#include <qwt6/qwt_plot.h>
+#include <qwt6/qwt_plot_curve.h>
+#include <qwt6/qwt_plot_grid.h>
+#include <qwt6/qwt_symbol.h>
+#include <qwt6/qwt_legend.h>
+#include <qwt6/qwt_plot_canvas.h>
+#include <qwt6/qwt_plot_panner.h>
+#include <qwt6/qwt_plot_zoomer.h>
+#include <qwt6/qwt_plot_renderer.h>
//#include <qwt/qwt_global.h>

namespace Ui {

esistenza_articoli-ui.patch

--- fabariagest-1.0/fabaria/ui/esistenza_articoli.ui 2015-05-17 21:56:50.000000000 +0200
+++ fabariagest-1.0/fabaria/ui/esistenza_articoli_new.ui 2015-06-12 09:48:06.512575766 +0200
@@ -86,7 +86,7 @@
<customwidget>
<class>QwtPlot</class>
<extends>QFrame</extends>
- <header>qwt/qwt_plot.h</header>
+ <header>qwt6/qwt_plot.h</header>
</customwidget>
</customwidgets>
<tabstops>

esistenza_articoli.patch

--- fabariagest-1.0/fabaria/esistenza_articoli.h 2015-05-24 16:45:10.000000000 +0200
+++ fabariagest-1.0/fabaria/esistenza_articoli_new.h 2015-06-12 09:47:34.020387638 +0200
@@ -6,17 +6,17 @@
#include <QtSql>
#include <QFileDialog>
#include <QCompleter>
-#include <qwt/qwt_plot.h>
-#include <qwt/qwt_plot_curve.h>
-#include <qwt/qwt_plot_grid.h>
-#include <qwt/qwt_symbol.h>
-#include <qwt/qwt_legend.h>
-#include <qwt/qwt_plot_canvas.h>
-#include <qwt/qwt_plot_panner.h>
-#include <qwt/qwt_scale_draw.h>
-#include <qwt/qwt_plot_zoomer.h>
-#include <qwt/qwt_plot_renderer.h>
-#include <qwt/qwt_plot_intervalcurve.h>
+#include <qwt6/qwt_plot.h>
+#include <qwt6/qwt_plot_curve.h>
+#include <qwt6/qwt_plot_grid.h>
+#include <qwt6/qwt_symbol.h>
+#include <qwt6/qwt_legend.h>
+#include <qwt6/qwt_plot_canvas.h>
+#include <qwt6/qwt_plot_panner.h>
+#include <qwt6/qwt_scale_draw.h>
+#include <qwt6/qwt_plot_zoomer.h>
+#include <qwt6/qwt_plot_renderer.h>
+#include <qwt6/qwt_plot_intervalcurve.h>

namespace Ui {
class esistenza_articoli;

In alcune distro non è disponibile il pacchetto python-dropbox, di conseguenza si deve compilare, se usate gli rpm, i deb o i PKGBUILD non c'è bisogno poichè sono già inclusi nei pacchetti precompilati.

Digitare i seguenti comandi:

curl "https://bootstrap.pypa.io/get-pip.py" -o "/tmp/get-pip.py"
python2.7 /tmp/get-pip.py
pip2.7 install dropbox

Pubblicità

Supporta lo sviluppo dei nostri progetti.

I cookie ci aiutano a fornire i nostri servizi. Utilizzando tali servizi, accetti l'utilizzo dei cookie da questo sito. Faq in materia di cookie